Semaphore signal error

Have you given it a go? Post your experiences, particularly things that worked well. Let the team know what works and doesn't work as they cannot test the software with every combination of routes, activities and content available for MSTS. OpenRails is actively being improved and is quickly approaching v1.0. This is a great place to discuss what you can do with OpenRails.

Moderator: Moderators

ozziedriver
Been on the forums for a while
Posts: 282
Joined: Sat Jul 02, 2005 11:52 pm
Location: Pakenham,victoria, Australia

Re: Semaphore signal error

Post by ozziedriver »

Were you have your ………. Home/Distant, Home/Distant, then a home
The distant ahead script should only be TWO (2) for that situation

The distant script reads the home on the same post as 0ne (1) then the next home as (2) then it reads the next distant as the end of the request
The distant script MUST read another distant signal along the track in advance to end the request
Your normal distant script is possibly (3) so you will need to add extra distant scripts for different situations
Ozzirdriver
kenpix
Getting the hang of things now
Posts: 85
Joined: Sun Nov 23, 2008 7:57 pm

Re: Semaphore signal error

Post by kenpix »

I amended "number clear ahead" to 4 as per coolhand's suggestion and this sorted some of the distants ok. There are still issues with a few, some with 1 or 2 homes before the next distant but none with more than 3. One odd thing is that one particular distant (on a combined home/distant post) clears just before the train reaches it, as does another single home signal. West Horndon's home signal doesn't clear at all! I'm not sure what causes these occurrences.
I shall live with the current problems as I don't have time to delve into this any further, and hope Open Rails developments will eventually lead to modificaions to make semaphore signalling more stable. Thanks to all who helped with suggestions.
kenpix
Getting the hang of things now
Posts: 85
Joined: Sun Nov 23, 2008 7:57 pm

Re: Semaphore signal error

Post by kenpix »

Postscript - West Horndon home now ok, the signal "pyramid" wasn't showing on the track!
Ken
Locked

Return to “[OR] General OpenRails Discussion”