Flickering Tracks in Open Rails

Have you given it a go? Post your experiences, particularly things that worked well. Let the team know what works and doesn't work as they cannot test the software with every combination of routes, activities and content available for MSTS. OpenRails is actively being improved and is quickly approaching v1.0. This is a great place to discuss what you can do with OpenRails.

Moderator: Moderators

Post Reply
PGH60
Well Established Forum Member
Posts: 690
Joined: Tue Dec 02, 2008 4:49 pm

Flickering Tracks in Open Rails

Post by PGH60 »

Hi having recently returned to OR and installed a few routes everything is running ok,except i am finding the tracks keep flickering when running an activity.Can anyone help please if there is a solution to stop this please.Thanks.Peter.
slipperman12
Very Active Forum Member
Posts: 5660
Joined: Mon Nov 12, 2007 9:50 am
Location: North Nottinghamshire, UK

Re: Flickering Tracks in Open Rails

Post by slipperman12 »

Hi Peter,
Try my utility!

 Click to view more informationOpen Rails utility - UKFS-Fix v2.2 [633103 bytes] - UKFS-Fix2.zip
File ID: 36632 Date: 16 Dec 2018 - 327 Downloads


Cheers,
Ged
Intel i5-4690K (3.5Ghz), Gigabyte GA-Z97P-D3 m/b, 8GB DDR3 RAM, NVIDIA GTX 750ti (2GB) graphics card, Asus Xonar DS sound card. Win 10 Pro 64-bit.
PGH60
Well Established Forum Member
Posts: 690
Joined: Tue Dec 02, 2008 4:49 pm

Re: Flickering Tracks in Open Rails

Post by PGH60 »

Hi Ged thanks but i installed the fix but i cannot see any change in the tracks,i am running MSTS and OR on Windows10.Thannks.Peter.
slipperman12
Very Active Forum Member
Posts: 5660
Joined: Mon Nov 12, 2007 9:50 am
Location: North Nottinghamshire, UK

Re: Flickering Tracks in Open Rails

Post by slipperman12 »

Hi Peter,
You didn't mention which routes had the 'flickering' tracks. As far as I'm aware, only those using UK FineScale tracks are affected.

I hadn't used the utility for a long time so just tried it on a new installation of the Demo Route (MT SCE (reduced version)) and it still works OK!

If it's really only the tracks which are flickering, and not vegetation, buildings, etc., have a look in your Global > Shapes folder and scroll down to the first UKFS file (if there are any). If the utility worked, the file will be dated the same as when you ran the program. If other items are also flickering, try setting the MultiSampling to 8x or 16x - this will be found in the Options > Video tab.

Cheers,
Ged
Intel i5-4690K (3.5Ghz), Gigabyte GA-Z97P-D3 m/b, 8GB DDR3 RAM, NVIDIA GTX 750ti (2GB) graphics card, Asus Xonar DS sound card. Win 10 Pro 64-bit.
PGH60
Well Established Forum Member
Posts: 690
Joined: Tue Dec 02, 2008 4:49 pm

Re: Flickering Tracks in Open Rails

Post by PGH60 »

Hi Ged sorry but i did not install the UKFS Fix v2.2 i thought i had done however when i try to run the installer it will not run, it says at the bottom Comp exe or Decomp exe not installed.Can you help on this please.Thanks.Peter.
slipperman12
Very Active Forum Member
Posts: 5660
Joined: Mon Nov 12, 2007 9:50 am
Location: North Nottinghamshire, UK

Re: Flickering Tracks in Open Rails

Post by slipperman12 »

Hi Peter,
I don't think you've read the instructions!!

I wasn't able to get permission to include Comp.exe and decomp.exe, so you have to download and install them, following details in the readme.

Cheers,
Ged
Intel i5-4690K (3.5Ghz), Gigabyte GA-Z97P-D3 m/b, 8GB DDR3 RAM, NVIDIA GTX 750ti (2GB) graphics card, Asus Xonar DS sound card. Win 10 Pro 64-bit.
PGH60
Well Established Forum Member
Posts: 690
Joined: Tue Dec 02, 2008 4:49 pm

Re: Flickering Tracks in Open Rails

Post by PGH60 »

Hi Ged thanks i have managed to download comp exe and decomp exe but after reading the instructions can you advice me please on where to install them as i have no idea, sorry about this.Thanks. Peter.
slipperman12
Very Active Forum Member
Posts: 5660
Joined: Mon Nov 12, 2007 9:50 am
Location: North Nottinghamshire, UK

Re: Flickering Tracks in Open Rails

Post by slipperman12 »

Hi Peter,
You can install comp.exe and decomp.exe wherever you like, but not in C:\Program Files or C:\Program Files (x86)!

For information, I put mine in C:\ConvertUtils. You need to know where they are so that you can run each of the executables to enable their Registry entries to be created.

Cheers,
Ged
Intel i5-4690K (3.5Ghz), Gigabyte GA-Z97P-D3 m/b, 8GB DDR3 RAM, NVIDIA GTX 750ti (2GB) graphics card, Asus Xonar DS sound card. Win 10 Pro 64-bit.
PGH60
Well Established Forum Member
Posts: 690
Joined: Tue Dec 02, 2008 4:49 pm

Re: Flickering Tracks in Open Rails

Post by PGH60 »

Hi Ged thanks but i am going to give up on this because i have extracted each Comp exe and Decomp exe file into a folder so i Know where they are, but how to get the UKFS FIx installer to work is beyond me now so i guess i will stick with the flickering tracks. Thanks.Peter.
slipperman12
Very Active Forum Member
Posts: 5660
Joined: Mon Nov 12, 2007 9:50 am
Location: North Nottinghamshire, UK

Re: Flickering Tracks in Open Rails

Post by slipperman12 »

Hi Peter,
i have extracted each Comp exe and Decomp exe file into a folder
?? Just in case you haven't done everything, here is a complete list :
1. Download recmp119.zip
2. Unpack this file to give 6 files, including Comp.zip and DeComp.zip
3. Unpack Comp.zip to give 3 files - Comp.CAB, setup.exe and SETUP.LST
4. Run setup.exe - change the installation folder from Program Files (x86) to whatever you like.
NOTE: the line should read : C:\<Your folder name>\Comp
5. Go to the folder you specified at 4. and open the Comp folder; run Comp.exe and when its screen appears, press the Exit button.
6. Unpack DeComp.zip to give 3 files - DeComp.CAB, setup.exe and SETUP.LST
7. Run setup.exe - change the installation folder from Program Files (x86) to the same one you specified at 4.
NOTE: the line should read : C:\<Your folder name>\DeComp
8 Go to the folder your specified at 4. and open the DeComp folder; run DeComp.exe and when its screen appears, press the Exit button.

If you've done all that, you need to install UKFS_Fix2. This is one of my 'normal' installers which will install into C:\UKFS-Fix2, by default. When items 1. to 8. above have been completed, double-click the UKFS-Fix v2.2 Desktop icon to start the program. Then you need to select the folder containing the UKFS shape files, which will be the SHAPES folder in the GLOBAL folder of the installation containing the route with the 'flickering' tracks. Then follow the on-screen instructions. Once the program is running, please DO NOT attempt to abort it!

I hope this enables you to successfully rid yourself of the 'flickering' tracks! Up to now there have been more than 860 downloads and yours is the only report of anyone having difficulty. Of course, everyone else could have been so completely flummoxed by the instructions that they just abandoned it - but I hope not!!

Cheers,
Ged
PGH60
Well Established Forum Member
Posts: 690
Joined: Tue Dec 02, 2008 4:49 pm

Re: Flickering Tracks in Open Rails

Post by PGH60 »

Hi Ged Thanks for all the information i will follow it step by step and see i can have some success.Peter
Post Reply

Return to “[OR] General OpenRails Discussion”